Back to the main page.

Bug 918 - compatibility issue with matlab2011a

Reported 2011-08-31 22:29:00 +0200
Modified 2012-08-23 14:02:09 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P1 normal
Assigned to: Jörn M. Horschig
Depends on:
See also:

Robert Oostenveld - 2011-08-31 22:29:08 +0200

On Wed Aug 31 13:40:33 Anna wrote: Hello, I have written yesterday about troubles while running ft_timelockstatistics. As it happens now, this seems to be a compatibility issue between matlab 2011 and the current fieldtrip version (which you can solve temporarily by using older versions of both). Best wishes, Anna. -------- please look at the mail archive and identify the problem. Since we don't have matlab2011a at the donders yet, we have to revisit this bug once we can reproduce it.

Jörn M. Horschig - 2011-09-07 17:19:41 +0200

Initial mail by Anna: Dear fieldtrip community, Until about two weeks ago I was using a batch to process group comparison statistics on MEG data using ft_timelockstatistics. A week later, the same batch was not working anymore, even on the same data. The error I get is the following: ??? Improper index matrix reference. Error in ==> clusterstat>makechanneighbstructmat at 520 [seld] = match_str(, cfg.neighbours(chan).label); Error in ==> clusterstat at 60 channeighbstructmat = makechanneighbstructmat(cfg); Error in ==> statistics_montecarlo at 320 [stat, cfg] = clusterstat(cfg, statrand, statobs,'issource',issource); Error in ==> statistics_wrapper at 290 [stat, cfg] = statmethod(cfg, dat, design, 'issource',issource); Error in ==> ft_timelockstatistics at 124 [stat, cfg] = statistics_wrapper(cfg, varargin{:}); Error in ==> myfunction_stats at 59 gpstat = ft_timelockstatistics(cfg, data1, data2); It seems the error concerns the 'neighbours.mat' file reading, even though I am not sure about it. When I delete the two last lines in this file (to match the size of matrix wanted) the error disappears, but the processing is incomplete and false (or at least it does not match the results I had before). Has anyone encounter the same issue? Did you do any update recently that might explain this problem, and do you have any idea how to remedy to it? Best wishes, Anna.

Jörn M. Horschig - 2011-11-23 14:45:21 +0100

just got a fresh install of 2011a this bug is second on my list

Jörn M. Horschig - 2011-11-30 10:32:01 +0100

sorry, I cannot reproduce this bug my assumption would be that Anna used an old neighbourhood definition (cell-array) and that fixneighbours was not implemented correctly back then, which converts the cell-array into a struct-array. I don't see the connection to matlab2011 for that explanation though... I tried with the tutorial data - should I ask Anna if she can check with the newest FT version if it all works now?

Robert Oostenveld - 2011-11-30 11:22:14 +0100

(In reply to comment #3) yes, please involve Anna (and CC her on this bug). She mentions a file "neighbours.mat". It would be useful to get that file for testing, also for future regression testing.

Boris Reuderink - 2012-02-03 21:49:16 +0100

Jorn, I am reopening this bug. Could you follow this up with Anna?

Jörn M. Horschig - 2012-02-06 16:59:34 +0100

Dear Jörn, thank you for your enquiry, however the bug is indeed already solved in the newer version. Best regards, Anna.

Jörn M. Horschig - 2012-08-23 14:02:09 +0200

bug closing time (