Back to the main page.

Bug 641 - hastrialdef should be renamed into hassampleinfo in ft_checkdata

Reported 2011-05-04 15:34:00 +0200
Modified 2011-07-13 14:20:34 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P1 normal
Assigned to: Eelke Spaak
Depends on:
See also:

Robert Oostenveld - 2011-05-04 15:34:19 +0200

the fixtrialdef function can stay as it is

Eelke Spaak - 2011-05-20 15:13:37 +0200

Should I also remove the hasoffset option? And then search for functions using this, and rewrite them? There are not too many functions using hasoffset: bash-3.2$ grep -l -R --include=*.m hasoffset . ./utilities/ft_checkdata.m ./utilities/ft_selectdata.m ./fileio/private/ft_checkdata.m ./compat/ft_freqanalysis_old.m ./ft_examplefunction.m ./ft_preprocessing.m ./ft_rejectvisual.m ./ft_rejectartifact.m ./ft_freqanalysis.m ./ft_databrowser.m Since I'll be going through a lot of functions anyway because of the related bug 654, I think hasoffset should be removed. (Maybe I should even change ft_definetrial and remove the third column..?)