Back to the main page.

Bug 438 - ft_checkdata should get siblings like ft_checkraw, ft_checkfreq, ft_checksource, ft_checkvolume

Reported 2011-01-26 22:02:00 +0100
Modified 2011-03-31 14:13:55 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P1 normal
Assigned to: Robert Oostenveld
Depends on:
Blocks: 395
See also:

Robert Oostenveld - 2011-01-26 22:02:35 +0100

each of these functions (in public) should do the checking (and are called by ft_checkdata) but mainly should be used to document the data structures perhaps the functions should be called ft_rawdata ft_timelockdata ft_freqdata to make them more easily to find.

Robert Oostenveld - 2011-01-31 18:02:04 +0100

I started creating ft_datatype_xxx, there is still work to be done

Robert Oostenveld - 2011-01-31 18:02:42 +0100

*** Bug 340 has been marked as a duplicate of this bug. ***

Robert Oostenveld - 2011-03-17 17:39:29 +0100

these have been implemented as ft_datatype_comp.m ft_datatype_dip.m ft_datatype_freq.m ft_datatype_mvar.m ft_datatype_raw.m ft_datatype_source.m ft_datatype_spike.m ft_datatype_timelock.m ft_datatype_vol.m

Robert Oostenveld - 2011-03-31 14:13:55 +0200

changed the status of most recently resolved/fixed bugs into "CLOSED"