Back to the main page.

Bug 3147 - interp_gridded is broken

Reported 2016-06-14 21:53:00 +0200
Modified 2016-11-29 09:01:37 +0100
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P5 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Jan-Mathijs Schoffelen - 2016-06-14 21:53:08 +0200

Due to a commit dating back to December 2014 (!), interp_gridded is broken. There's a mix up between a variable which I think was originally called 'pnt', and was changed into 'pos' by our always zealous general. This causes a clash with the also (already prior to the change) defined 'pos'. I have already started a separate branch and fixed the code (using pos_to and pos_from consistently). While I am at it, I suggest to also use this naming convention in interp_ungridded (which uses pntin and pntout).

Jan-Mathijs Schoffelen - 2016-07-05 20:59:35 +0200

I pushed this a while ago. Should work now