Back to the main page.

Bug 2698 - fieldtrip is bugging out eeglab extensions

Reported 2014-09-22 23:54:00 +0200
Modified 2015-01-12 09:20:34 +0100
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P5 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Spencer - 2014-09-22 23:54:09 +0200

I am getting an error when I attempt to use Cleanline in EEGLAB. I have Matlab R2013B and EEGLAB 13.3.2. I have tried several different data files (epoched and continuous) with no success. I always get the same error, which I have pasted below. Thanks! Spencer Fix Error using dpss Too many input arguments. Error in dpsschk (line 28) [tapers,eigs]=dpss(N,tapers(1),tapers(2)); Error in rmlinesmovingwinc (line 94) params.tapers=dpsschk(tapers,Nwin,Fs); % check tapers Error in cleanline (line 349) [datac,datafit,amps,freqs]=rmlinesmovingwinc(data,movingwin,tau,params,p,fastif(plotfigures,'y','n'),linefreqs,fastif(scanforlines,params.tapers(1),[])); Error in pop_cleanline (line 50) [EEGclean, Sorig, Sclean, f, amps, freqs, g] = cleanline('EEG',EEG,g);

Jan-Mathijs Schoffelen - 2014-09-24 14:17:50 +0200

This looks like a user error to us. In your error report there's no mention of a Fieldtrip-function being called explicitly. The only thing that could have happened, is that MATLAB is using the drop-in replacement of dpss in fieldtrip/external/signal/dpss_hack. MATLAB will only arrive here if your path settings have the mentioned folder higher on the path than the expected signal processing toolbox folder. Most likely this is caused by the user doing a addpath(genpath('')) type of thing, which is explicitly discouraged on the FieldTrip website. Please also have a look at the README documentation in the dpss_hack folder.