Back to the main page.

Bug 224 - rename and documentation of fieldtripdefs.m

Reported 2010-11-17 17:33:00 +0100
Modified 2011-02-09 16:17:40 +0100
Product: FieldTrip
Component: documentation
Version: unspecified
Hardware: All
Operating System: All
Importance: P1 enhancement
Assigned to: Johanna
Depends on:
See also:

Johanna - 2010-11-17 17:33:44 +0100

Some suggested changes to fieldtripdefs.m 1) Change name to ft_defaults.m for consistency 2) Create reference page on wiki for this function. (identical to 'help ft_defaults.m') 3) Add FAQ on wiki to tell a user when/where to call it, and how to modify the defaults for user-specific needs (independent of modifying the code itself). (The existing FAQ refers to paths only:[]=fieldtripdefs )

Johanna - 2010-12-17 16:49:26 +0100

Items (1) and (2) are completed, as well as mentions of fieldtripdefs in the wiki. However, fieldtripdefs.m compatibility file now still resides in trunk rather than compat folder. Should it be left like this for users calling fieldtripdefs from their own scripts? I don't have anything to add for (3). Does someone else want to do this, or declare it not necessary?