Back to the main page.

Bug 2131 - enginepool fails to start

Reported 2013-04-22 19:57:00 +0200
Modified 2019-08-10 11:20:07 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P3 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Robert Oostenveld - 2013-04-22 19:57:50 +0200

I tried "enginepool open 4" on my mac desktop, but it blocked after starting two in the background and I had to kill MATLAB.

Robert Oostenveld - 2014-05-14 11:52:10 +0200

mac011> svn commit Sending engine.mexmaci64 Sending ft_getopt.mexmaci64 Transmitting file data .. Committed revision 9522. the following reproduces the initial problem, i.e. MATLAB hangs >> enginepool open 2 >> enginecellfun(@randn, {1, 2}) I guess there is a mutex problem

Robert Oostenveld - 2019-08-10 11:20:07 +0200

this issue is very old. However, I just tried to start an enginepool om 2019a on mac036, and it does not reproduce. Instead, it crashes MATLAB :-( Looking at the git commit message corresponding to SVN rev 9522, I see it is from May 2014, and it refers to MATLAB 2014a. Another recompile for maci64 was done in Dec 2014. The a64 version for Linux was recompiled the last time in Sept 2013. In trying to make this work on 2019a, I suggest to first try and replicate the state of affairs in 2013/2014, with the corresponding (old) MATLAB versions.