Back to the main page.

Bug 1414 - fix the test scripts

Reported 2012-04-12 09:50:00 +0200
Modified 2016-06-14 16:14:52 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P3 normal
Assigned to: Robert Oostenveld
Depends on: 701042
See also:

Robert Oostenveld - 2012-04-12 09:50:38 +0200

reminder to myself: test_ft_selectdata, test_bug576, test_qsubcellfun, test_bug70, test_bug1042

Robert Oostenveld - 2012-04-15 11:48:49 +0200

I traced down test_bug576: There were some issues, but I got stuck on ft_senstype not detecting that it is neuromag122 or neuromag306 (but rather meg). This is due to comp.grad being the balanced version and containing the pca labels rather than the MEG labels. This is something that I won't fix here and now, so I made a workaround in the test script.

Robert Oostenveld - 2012-04-15 12:04:18 +0200

I traced down test_bug70: The first error is due to bem_openmeeg being renamed to openmeeg. I fixed that with a "renamedval" in ft_prepare_headmodel. I also updated the test script itsellf. roboos@mentat001> svn commit ft_prepare_headmodel.m test/test_bug70.m Sending ft_prepare_headmodel.m Sending test/test_bug70.m Transmitting file data .. Subsequently it gets stuck in not being able to execute openmeeg. I reopened bug #70 and added a description there.

Robert Oostenveld - 2012-04-15 12:17:33 +0200

I traced down test_qsubcellfun: This wa s a silly error, causing fieldtrip/peer to be on the path instead of fieldtrip/qsub. With the correct path it now works fine.

Robert Oostenveld - 2012-04-15 13:04:33 +0200

I traced down test_bug1042: One of the problems was the (elsewhere also occurring) rename of the volume conductor type names from bem_dipoli into dipoli and bem_openmeeg into openmeeg. I already fixed those. There was also bem_cp, which I renamed into the original bemcp (and added a renamedval option to ft_prepare_headmodel). The second set of problems I ran into is that the input geometry variable into ft_headmodel_xxx has apparently changed. The test script gives them other inputs than what the functions now expect. I have made the forward/ft_headmodel_xxx functions more robust for the input geometry. roboos@mentat001> svn commit ft_prepare_headmodel.m Sending ft_prepare_headmodel.m Transmitting file data . Committed revision 5623. roboos@mentat001> svn commit Sending forward/ft_headmodel_concentricspheres.m Sending forward/ft_headmodel_localspheres.m Sending forward/ft_headmodel_singlesphere.m Transmitting file data ... Committed revision 5624. roboos@mentat001> svn commit Sending forward/ft_headmodel_concentricspheres.m Sending forward/ft_headmodel_singlesphere.m Transmitting file data .. Committed revision 5625. The test script gets quite far, but at a certain moment it gets stuck in the openmeeg volume conduction models. Since that was also the case for test_bug70, I'll file it as a new bug #1426 and assign that to Cristiano.

Robert Oostenveld - 2012-04-15 13:31:29 +0200

I traced down test_ft_selectdata: There was an incorrect call to the old-style ft_selectdata (no parameter specified). Furthermore, ft_selectdata did not correctly detect the old-style input, causing it to end up in the new-style code. roboos@mentat001> svn commit test/test_ft_selectdata.m utilities/ft_selectdata.m Sending test/test_ft_selectdata.m Sending utilities/ft_selectdata.m Transmitting file data .. Committed revision 5627.

Robert Oostenveld - 2012-04-15 13:32:43 +0200

reminder to myself: test_ft_selectdata, test_bug576, test_qsubcellfun have been resolved test_bug70, test_bug1042 are still not working as they are blocked by bug #1426

Robert Oostenveld - 2012-04-15 13:42:45 +0200

(In reply to comment #6) this one still fails but it is due to a failure to run MATLAB with qsub. Probably the cluster is too busy, causing the test script to take too long, causing the parent MATLAB to be killed because not enough time was allocated for it. To be discussed with Boris.

Robert Oostenveld - 2012-06-13 09:09:40 +0200

(In reply to comment #6) although bug #1426 has been resolved, test_bug70 and test_bug1042 are still failing.

Robert Oostenveld - 2012-10-29 22:37:09 +0100

(In reply to comment #8) test_bug1042 now seems to run, i.e. it does not result in an explicit error.

Jim Herring - 2013-06-07 09:12:51 +0200

test_beamforming_extended fails in the dashboard but does not exist anymore in fieldtrip/test. It was renamed to test_tutorial_beamforming_extended, which passes in the dashboard.

Robert Oostenveld - 2016-02-05 13:15:02 +0100

test scripts have recently been working fine, no reason to keep this open

Robert Oostenveld - 2016-06-14 16:14:52 +0200

Hereby I am closing multiple bugs that have been resolved for some time now. If you don't agree to the resolution, please reopen.